블로그 이미지
장피디
나는야 장피디님

calendar

      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  

Notice

2014.06.11 16:30 OS/HP-UX::












HP-UX에서 acc 컴파일러를 사용하다가 갑자기 포맷하는 일이 생겨서 어쩔 수 없이 gcc를 설치하게 되었다.


gcc를 설치하려니 여러가지 dependencies 패키지가 발생했는데 우선 내가 설치하다가 걸린 패키지들은 아래와 같다.


gettext

libiconv

zlib

libgcc


뭐 버전에 따라서 차이가 있을 수 있지만 swinstall로 설치할때는 zlib와 libgcc만 표시가 되었는데

실제 설치해보니 libiconv, gettext가 걸렸다. 


기본적으로 /usr/gnome/lib 쪽에 설치는 되어 있는 것으로 확인되었지만 해당 부분은 내가 설치한 것도 아니고 링크를 걸어도

정상적으로 인식이 되지 않아 별도로 패키지를 구해서 설치하니 정상적으로 표시되었다.


마지막에 


/usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libintl.sl
/usr/lib/dld.sl: No such file or directory
Abort(coredump)


해당 부분이 발생해서 당황했었지만 이는 gettext 라이브러리를 설치해주면 해결되는 현상.


HP-UX 설치 패키지들은 아래의 경로에서 다운 받았다.

URL : http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=2a08725cc2f02110725cc2f02110275d6e10RCRD (HP공식 - HP 가입해야합니당)

URL : http://hpux.connect.org.uk/

URL : http://mirrors.develooper.com/hpux/downloads.html

URL : http://gnu.april.org/software/gcc/gcc-4.4/buildstat.html


--------------------------------------------------------------------------------------------


위 같이... 설치해 보았지만 골 때리는 현상을 발견했다.

-m32 -m64 와 같은 비트 옵션이 먹지 않는다는 사실.


이게 왜 이런가 하고 한참 동안 삽질 하다가 HP 공식 홈페이지를 통해서 확인한 사실은 내가 영어 해석을 잘 못해서 그런데

대충 해석해보니 32비트용 gcc랑 64비트 gcc를 둘다 깔아야 한다. 라는 얘기로 보인다.


자세한 얘기는 아래의 링크...

http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=2a08725cc2f02110725cc2f02110275d6e10RCRD


There are two separate GCC packages for PA-RISC, one that generates ILP32 code, and another that generates LP64 code. The 32-bit version is installed in the /opt/hp-gcc directory, and the 64-bit version is installed in /opt/hp-gcc64.


심지어 깔리는 위치도 각각 다르다... 

일단 둘다 깔아야 겠다... 나중에 다시 한번 확인해봐야겠다 ㅠ



저작자 표시 비영리 변경 금지
신고
posted by 장피디
prev 1 ... 44 45 46 47 48 49 50 51 52 ... 247 next

티스토리 툴바